WordPressのサーバー要件とは?各バージョンの推奨環境

最終更新日:

WordPressを動作させるためにはPHPとMySQLがインストールされたサーバーが必要です。WordPressのバージョンごとに推奨されているPHPとMySQLのバージョンをまとめました。

サーバー要件

最新のWordPress 5.5を動作させるためには以下の要件を満たしていることが推奨されています。

下記でそれぞれの要件について概要を説明します。

PHP

PHPはWordPressの開発や保守に使用されているプログラミング言語です。

PHPの新しいバージョンはより高速で安全なため、最新の状態を維持することにより、サイトの全体的なパフォーマンスとセキュリティが向上します。

PHPの最低推奨バージョンは7.4です。

MySQLまたはMariaDB

SQLサーバーは、WordPressがサイトのコンテンツや設定を保存する際に使用するデータベースとして必要なソフトウェアです。

MySQLの最低推奨バージョンは5.6、MariaDBの最低推奨バージョンは10.1以上です。

HTTPS対応

HTTPSとはHyperText Transfer Protocol Secureの略称です。HTTPSは暗号化された通信プロトコルです。

HTTPS接続を用いることでより安全にウェブサイトを閲覧することができます。今では多くのサービスにおいて、HTTPSは必須要件のひとつとされています。

サイトのスピード向上、検索ランキングの改善、サイト訪問者のオンラインプライバシー保護を助けることによる信頼の獲得など、HTTPSはさまざまな恩恵をもたらします。

各バージョンの推奨環境

WordPressの各バージョンで推奨されているPHPとMySQLのバージョンは下記の表の通りです。

WordPressPHPMySQL(MariaDB)
5.4.2~7.4以上5.6以上(10.1以上)
5.2 ~ 5.4.17.3以上5.6以上(10.1以上)
5.0 ~ 5.1系7.3以上5.6以上(10.0以上)
4.9.5 ~ 4.9.137.2以上5.6以上(10.0以上)
4.9.0 ~ 4.9.47.0以上5.6以上(10.0以上)
4.7 ~ 4.8系7.0以上5.6以上(10.0以上)
4.0 ~ 4.6系5.6以上5.6以上(10.0以上)
3.2 ~ 3.9系5.2.4以上5.0以上
2.9 ~ 3.1系4.3以上4.1.2以上
2.5 〜 2.8系4.3以上4.0以上
2.1 ~ 2.3系4.2以上4.0以上
2.0.x系4.2以上3.23.23以上

推奨環境以外でも動作するのか?

WordPressは古いPHPやMySQLでも動作しますが、セキュリティの脆弱性をつかれる危険性があります。

推奨環境にアップデートすることをおすすめします。

関連記事

よく見られている記事

  1. WordPress 5.5で何が新しくなったのか?新機能や変更点を紹介
  2. WordPressをローカル環境にインストールする方法
  3. WordPressのサーバー要件とは?各バージョンの推奨環境
  4. WordPress 5.4で何が新しくなったのか?新機能や変更点
  5. WordPressで画像にwidthとheightを追加する方法
  6. WordPressにログインできない?13の解決方法
  7. WordPress 5.4.2の更新内容は?6つのセキュリティ問題の修正
  8. WordPressのおすすめ無料テーマまとめ(用途別)

新しい記事

go to top